Decodo - Partial website disruption – Incident details

All systems operational

Partial website disruption

Resolved
Partial outage
Started 2 months agoLasted 37 minutes

Affected

Decodo Website

Operational from 10:27 AM to 11:03 AM

Updates
  • Resolved
    Resolved

    The issue with our website access has been resolved

  • Investigating
    Investigating

    Our main page might be unreachable. We are currently working on resolving this issue.